Camel Spring possible version problem.

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

Camel Spring possible version problem.

sekaijin
This post has NOT been accepted by the mailing list yet.
Hi
I'm trying to run camel-jpa on servicemix 6.1.2.
I've somme errors.

I have seen that camel-jpa is compiled with the dependency spring-orm 4.1.9.RELEASE but the bundle imports versions [3.2,5) and the feature define the versions [3.2,4)

When I install camel-jpa
>feature:install camel-jpa
I get
>feature:list -i |grep spring
spring                          | 3.2.14.RELEASE_1 | x         | spring-3.0.6                   | Spring 3.2.x support
spring-jdbc                     | 3.2.14.RELEASE_1 | x         | spring-3.0.6                   | Spring 3.2.x JDBC support
spring-orm                      | 3.2.14.RELEASE_1 | x         | spring-3.0.6                   | Spring 3.2.x ORM support
spring-tx                       | 3.2.14.RELEASE_1 | x         | spring-3.0.6                   | Spring 3.2.x Transaction (TX) support
camel-spring                    | 2.16.2           | x         | camel-2.16.2                   |
> feature:list -i |grep jpa
camel-jpa                       | 2.16.2           | x         | camel-2.16.2                   |
openjpa                         | 2.3.0            | x         | enterprise-3.0.6               | Apache OpenJPA 2.3.x persistence engine support

http://karaf.922171.n3.nabble.com/Karaf-3-0-6-JPA-2-3-0-Pax-JDBC-1-1-0-tt4051155.html
http://openjpa.208410.n2.nabble.com/Karaf-3-0-6-JPA-2-3-0-Pax-JDBC-1-1-0-and-java8-td7590380.html


A+JYT
PS I have the same problem in java 1.8 and 1.7