Embedded Activemq in servicemix shuts down when done installing bundles through feature descriptor

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

Embedded Activemq in servicemix shuts down when done installing bundles through feature descriptor

maggie
Summary: Embedded Activemq in servicemix shuts down when done installing
bundles through feature descriptor

Environment:
Linux OS: Red Hat Enterprise Linux Server release 6.9
Servicemix: 6.1.1
Java: 1.8.0_92
Jenkins version 2.8

Description:
We have been setting up our integration environments by installing required
bundles on servicemix using the servicemix client. We recently our
integration servers to 6.9 from RHEL  6.4

For some reason, when running exact same script to deploy the bundles on
new linux server, the activemq shuts down. There is no error but just log
message with INFO level saying Apache ActiveMQ XXX is shutting down.
Servicemix becomes unusable after this. There is no trace of error before
this message.

We have not been able to trace down what exactly triggers the shutdown.

Same script does not reproduce the issue when executed manually. Even more
interesting is that the script if used by a different jenkins pipeline also
does not reproduce the issue.

This has been very strange issue, pretty much leaving us clueless on why is
this happening.

Any help on this will be highly appreciated. This is current blocking our
release.

Thanks
Vaibhav