Guava version range too restrictive for org.apache.servicemix.bundles.opensaml

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

Guava version range too restrictive for org.apache.servicemix.bundles.opensaml

amergey
Hello,

org.apache.servicemix.bundles.opensaml bundle requires guava 18 only (19 is excluded), it is a bit too restrictive and leads to insconsistency with recent version of cxf
- cxf security requires opensaml which strictly requires guava 18
- cxf swagger feature requires some dependencies that requires guava 20

Regards,
Arnaud
Reply | Threaded
Open this post in threaded view
|

Re: Guava version range too restrictive for org.apache.servicemix.bundles.opensaml

amergey
The new org.apache.servicemix.bundles.opensaml requires guava 19 (with 20 excluded) so cxf swagger feature still cannot be used in osgi

Regards
Reply | Threaded
Open this post in threaded view
|

Re: Guava version range too restrictive for org.apache.servicemix.bundles.opensaml

Jean-Baptiste Onofré
Thanks for the update, I'm extending the guava version range.

Regards
JB

On 06/16/2017 03:45 PM, amergey wrote:

> The new org.apache.servicemix.bundles.opensaml requires guava 19 (with 20
> excluded) so cxf swagger feature still cannot be used in osgi
>
> Regards
>
>
>
> --
> View this message in context: http://servicemix.396122.n5.nabble.com/Guava-version-range-too-restrictive-for-org-apache-servicemix-bundles-opensaml-tp5724370p5724605.html
> Sent from the ServiceMix - User mailing list archive at Nabble.com.
>

--
Jean-Baptiste Onofré
[hidden email]
http://blog.nanthrax.net
Talend - http://www.talend.com