Issue/Bug with Servicemix-web 3.2.1 (WAR)

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

Issue/Bug with Servicemix-web 3.2.1 (WAR)

Puneet Jain
Hi,

I am trying to integrate servicemix with Geronimo.
I have written the http-uploader sample application given in the tutorial of servicemix at below location
http://servicemix.apache.org/7-intermediate-writing-a-http-upload-application.html

It runs fine with standalone servicemix. But when, I tried to run this application with servicemix running in Geronimo, it’s not working properly. When we tried the same on the Servicemix, it shows file save dialog box. The same is not working, when tried on Geronimo.

Note: No exception is coming

I have put the logging statements in the HttpMarshler and HttpHandler Bean classes and run it. I have observed that the createMessage() method of HttpMarshler is getting called. onMessageExchange() method of HttpHandler is also called. But the sendOut method of HttpMarshler is not getting called.

The example is using the http:consumer element in xbean.xml file:
<http:consumer   service="ex:httplistener"
                 endpoint="listenerEndpoint"
                 locationURI="http://0.0.0.0:8192/upload/" 
                 defaultMep="http://www.w3.org/2004/08/wsdl/in-out" 
                 targetService="ex:httphandler"
                 marshaler="#marshaler" />
And This element is existing in ServiceMix version 3.2 and above only (As mentioned in the tutorial).

Since this element is new in servicemix, the handling of this element is having some issue when it is used with apache servicemix-web (WAR) in Geronimo.

Environment:
=========
Operating System – Windows XP SP2
Servicemix 3.2.1
Geronimo with tomcat version 2.0.2
Java 1.5

Steps Performed:
============

1. Downloaded the “apache-servicemix-web-3.2.1.zip” file from below location and deployed it on Geronimo.
        http://servicemix.apache.org/download.html

2. Installed servicemix-shared library using the apache servicemix-web interface’s Shared Libraries Menu.
3. Installed and started servicemix-http and servicemix-bean component using the servicemix-web interface’s Components menu.
4. Deployed and started the http-uploader-sa service assembly using the same interface’s Service assemblies menu.
5. Verified that the service is deployed using below url:
        http://localhost:8080/apache-servicemix-web-3.2.1.zip/jbi/

6. I have written a client as per instruction given in the tutorial and change the  “action” in the HTML form tag  with the following URL:
        http://localhost:8080/apache-servicemix-web-3.2.1.zip/jbi/upload 
7. When, I tried to access the application, nothing got displayed on the browser. i.e.  no response comes back.

Exception:
======
There is no Exception comes in any log.


Please help me in resolving this problem. I am stuck with this problem from long time and have sent so many mails, but have not got any pointers to solve to this problem.

Looking forward for your reply at the earliest..!

Thanks,
Puneet