POI bundle and dependencies

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

POI bundle and dependencies

Arnaud Yahoo
Hello,

I was using poi 4.0.1_1 bundle in a project. I tried to upgrade to
4.1.0_1 but it requires xmlbeans now

(in previous version xmlbeans was packaged inside POI bundle).

Trying to import xmlbeans bundle from servicemix, it cannot be used
because it imports net.sf.saxon.dom as required package.

It seems it is not expected as net.sf.saxon dependence is supposed to be
optional right ?

Arnaud


Reply | Threaded
Open this post in threaded view
|

Re: POI bundle and dependencies

Arnaud Yahoo
Hello,

Am I the only one to have this dependence issue with POI 4.1 bundle ?

Thanks,

Arnaud

On 12/06/2019 09:44, Arnaud Yahoo wrote:

> Hello,
>
> I was using poi 4.0.1_1 bundle in a project. I tried to upgrade to
> 4.1.0_1 but it requires xmlbeans now
>
> (in previous version xmlbeans was packaged inside POI bundle).
>
> Trying to import xmlbeans bundle from servicemix, it cannot be used
> because it imports net.sf.saxon.dom as required package.
>
> It seems it is not expected as net.sf.saxon dependence is supposed to
> be optional right ?
>
> Arnaud
>
>