external Endpoint bug ??

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

external Endpoint bug ??

Charles Souillard
Hi all,

as you probably know by now I have a service available in my SE.

I am trying to expose this service through many BCs.

I have done that with sm-jms and sm-http.
In the source code, when we deploy a new SU with the consumer role, both
in sm-jms and sm-http, a registerExternalEndpoint is performed.

I am able to make the two cases running independently. The problem is
when I put the two SUs (1 for sm-jms and 1 for sm-http) in SM. For the
second one, I get the following exception :

An external endpoint for service
{urn:helloworld:bpel:bsoap}HelloWorldServiceBP and endpoint HelloWorld
is already registered

Perhaps I am doing something wrong or it is a bug.... ?

Regards,
Charles

Reply | Threaded
Open this post in threaded view
|

Re: external Endpoint bug ??

Guillaume Nodet
Administrator
See SM-369

Guillaume

On 3/27/06, Charles Souillard <[hidden email]> wrote:

> Hi all,
>
> as you probably know by now I have a service available in my SE.
>
> I am trying to expose this service through many BCs.
>
> I have done that with sm-jms and sm-http.
> In the source code, when we deploy a new SU with the consumer role, both
> in sm-jms and sm-http, a registerExternalEndpoint is performed.
>
> I am able to make the two cases running independently. The problem is
> when I put the two SUs (1 for sm-jms and 1 for sm-http) in SM. For the
> second one, I get the following exception :
>
> An external endpoint for service
> {urn:helloworld:bpel:bsoap}HelloWorldServiceBP and endpoint HelloWorld
> is already registered
>
> Perhaps I am doing something wrong or it is a bug.... ?
>
> Regards,
> Charles
>
>