RE: org.apache.servicemix.bundles.poi 4.0.0_1 not osgi deployable can't resolve all dependencies
Am I on the right forum? I would like to issue a bug report now, these poi servicemix osgi bundles are not osgi compliant. They are undeployable in JBoss Fuse Karaf OSGI container. And there are dependencies that cannot be resolved. One will need to create their own osgi bundle because I haven't found 1 that works except 3.9_2, however, there is no workbook.close() method.
Will you be making an osgi deployable, workable, out of box bundle? Or should I fumble through it? I've not done this before so any help would be great. Thanks so much
From: Mills, Gary (GE Digital)
Sent: Thursday, December 20, 2018 5:07 PM
To: [hidden email] Subject: org.apache.servicemix.bundles.poi 4.0.0_1 not osgi deployable can't resolve all dependencies
Hello, I am trying to upgrade from org.apache.servicemix.buncles.poi.3.9_2 to 4.0.0_1 (*thanks
I inherited an application that used 3.9_2, simply to read xlsx spreadsheets and update a
I needed to write an app to read in a template, update the template with message exchange
data, then send the xlsx workbook to some destination. I had it all working with 3.9_2, however,
there is no workbook.close() method in 3.9_2. So, I opted to upgrade to 4.0.0_1. On my journey
I tried each release up to 4.0.0_1 unsuccessfully. I then just settled on 4.0.0_1 to try
to get it working.
I'm almost there, however, I cannot resolve alll the dependencies.
Error executing command: Could not start bundle mvn:com.ge.ip.infra/delta-fadec-prod/3.0.1-SNAPSHOT
in feature(s) fadec-application-1.0.0: Unresolved constraint in bundle delta-fadec-prod :
Unable to resolve 348.0: missing requirement [348.0] osgi.wiring.package; (&(osgi.wiring.package=org.apache.poi.ss.usermodel)(version>=4.0.0)(!(version>=5.0.0)))