[servicemix-user] 2.0 build failed

classic Classic list List threaded Threaded
8 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

[servicemix-user] 2.0 build failed

nsowatsk
1.1 builds fine, but ...

rcdn-nsowatsk-3002-1:~/Documents/workspace/servicemix-2.0 nsowatsk$  
maven
__  __
|  \/  |__ _Apache__ ___
| |\/| / _` \ V / -_) ' \  ~ intelligent projects ~
|_|  |_\__,_|\_/\___|_||_|  v. 1.1-beta-2

DEPRECATED: the default goal should be specified in the <build>  
section of project.xml instead of maven.xml
build:start:

init:
     [echo] init basedir=/Users/nsowatsk/Documents/workspace/
servicemix-2.0

default:
multiproject:projects-init:
     [echo] Gathering project list
Starting the reactor...

BUILD FAILED
File...... /Users/nsowatsk/.maven/cache/maven-multiproject-
plugin-1.4.1/plugin.jelly
Element... maven:reactor
Line...... 64
Column.... -1
Unknown error reading project
Total time   : 4 seconds
Finished at  : Tuesday, November 8, 2005 12:23:17 PM CET

rcdn-nsowatsk-3002-1:~/Documents/workspace/servicemix-2.0 nsowatsk$

Nathan Sowatskey - Technical Leader, NMTG CTO Engineering -  
+34-638-083-675, +34-91-201-2139 - AIM NathanCisco - [hidden email]
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: [servicemix-user] 2.0 build failed

aschilling
I'm also having problems building 2.0.
Does anybody know how long it will take to fix this?

Thanks!

Andreas





                                                                                                                                     
                      Nathan Sowatskey                                                                                                
                      <nsowatsk@cisco.         An:      [hidden email]                                                  
                      com>                     Kopie:                                                                                
                                               Thema:   [servicemix-user] 2.0 build failed                                            
                      08.11.2005 12:24                                                                                                
                      Bitte antworten                                                                                                
                      an user                                                                                                        
                                                                                                                                     
                                                                                                                                     




1.1 builds fine, but ...

rcdn-nsowatsk-3002-1:~/Documents/workspace/servicemix-2.0 nsowatsk$
maven
__  __
|  \/  |__ _Apache__ ___
| |\/| / _` \ V / -_) ' \  ~ intelligent projects ~
|_|  |_\__,_|\_/\___|_||_|  v. 1.1-beta-2

DEPRECATED: the default goal should be specified in the <build>
section of project.xml instead of maven.xml
build:start:

init:
     [echo] init basedir=/Users/nsowatsk/Documents/workspace/
servicemix-2.0

default:
multiproject:projects-init:
     [echo] Gathering project list
Starting the reactor...

BUILD FAILED
File...... /Users/nsowatsk/.maven/cache/maven-multiproject-
plugin-1.4.1/plugin.jelly
Element... maven:reactor
Line...... 64
Column.... -1
Unknown error reading project
Total time   : 4 seconds
Finished at  : Tuesday, November 8, 2005 12:23:17 PM CET

rcdn-nsowatsk-3002-1:~/Documents/workspace/servicemix-2.0 nsowatsk$

Nathan Sowatskey - Technical Leader, NMTG CTO Engineering -
+34-638-083-675, +34-91-201-2139 - AIM NathanCisco - [hidden email]




Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: [servicemix-user] 2.0 build failed

Guillaume Nodet-3
In reply to this post by nsowatsk
Servicemix is built with maven-1.0.2.
I've just checked that the source distribution compiles well.
You must have a jdk 5 installed to compile, even if servicemix
is 1.4 compatible (some components use java 5 annotations, like jax-ws ...)

This may be a bug with maven 1.1 beta.

Guillaume

Nathan Sowatskey wrote:

> 1.1 builds fine, but ...
>
> rcdn-nsowatsk-3002-1:~/Documents/workspace/servicemix-2.0 nsowatsk$  
> maven
> __  __
> |  \/  |__ _Apache__ ___
> | |\/| / _` \ V / -_) ' \  ~ intelligent projects ~
> |_|  |_\__,_|\_/\___|_||_|  v. 1.1-beta-2
>
> DEPRECATED: the default goal should be specified in the <build>  
> section of project.xml instead of maven.xml
> build:start:
>
> init:
>     [echo] init basedir=/Users/nsowatsk/Documents/workspace/
> servicemix-2.0
>
> default:
> multiproject:projects-init:
>     [echo] Gathering project list
> Starting the reactor...
>
> BUILD FAILED
> File...... /Users/nsowatsk/.maven/cache/maven-multiproject-
> plugin-1.4.1/plugin.jelly
> Element... maven:reactor
> Line...... 64
> Column.... -1
> Unknown error reading project
> Total time   : 4 seconds
> Finished at  : Tuesday, November 8, 2005 12:23:17 PM CET
>
> rcdn-nsowatsk-3002-1:~/Documents/workspace/servicemix-2.0 nsowatsk$
>
> Nathan Sowatskey - Technical Leader, NMTG CTO Engineering -  
> +34-638-083-675, +34-91-201-2139 - AIM NathanCisco - [hidden email]
>
>

Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: [servicemix-user] 2.0 build failed

aschilling
In reply to this post by nsowatsk
Ok, with Maven 1.0.2 the build is succesful (sorry, didn't notice that the
path was still pointing to the 1.1 version).
But I still have problems building the war.
After "maven war" the resulting war-file only contains the manifest file.

Andreas




                                                                                                                                           
                      Guillaume Nodet                                                                                                      
                      <guillaume.nodet@worl         An:      [hidden email]                                                  
                      donline.fr>                   Kopie:                                                                                
                                                    Thema:   *****SPAM***** Re: [servicemix-user] 2.0 build failed                        
                      08.11.2005 13:30                                                                                                    
                      Bitte antworten an                                                                                                  
                      user                                                                                                                
                                                                                                                                           
                                                                                                                                           




Servicemix is built with maven-1.0.2.
I've just checked that the source distribution compiles well.
You must have a jdk 5 installed to compile, even if servicemix
is 1.4 compatible (some components use java 5 annotations, like jax-ws ...)

This may be a bug with maven 1.1 beta.

Guillaume

Nathan Sowatskey wrote:

> 1.1 builds fine, but ...
>
> rcdn-nsowatsk-3002-1:~/Documents/workspace/servicemix-2.0 nsowatsk$
> maven
> __  __
> |  \/  |__ _Apache__ ___
> | |\/| / _` \ V / -_) ' \  ~ intelligent projects ~
> |_|  |_\__,_|\_/\___|_||_|  v. 1.1-beta-2
>
> DEPRECATED: the default goal should be specified in the <build>
> section of project.xml instead of maven.xml
> build:start:
>
> init:
>     [echo] init basedir=/Users/nsowatsk/Documents/workspace/
> servicemix-2.0
>
> default:
> multiproject:projects-init:
>     [echo] Gathering project list
> Starting the reactor...
>
> BUILD FAILED
> File...... /Users/nsowatsk/.maven/cache/maven-multiproject-
> plugin-1.4.1/plugin.jelly
> Element... maven:reactor
> Line...... 64
> Column.... -1
> Unknown error reading project
> Total time   : 4 seconds
> Finished at  : Tuesday, November 8, 2005 12:23:17 PM CET
>
> rcdn-nsowatsk-3002-1:~/Documents/workspace/servicemix-2.0 nsowatsk$
>
> Nathan Sowatskey - Technical Leader, NMTG CTO Engineering -
> +34-638-083-675, +34-91-201-2139 - AIM NathanCisco - [hidden email]
>
>




Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: [servicemix-user] 2.0 build failed

Guillaume Nodet-3
In which directory do you call "maven war" ?
Look at http://servicemix.org/Tomcat+Integration
You must run the command in the \tooling\servicemix-web dir.
It works for me with the source dist.

Guillaume


[hidden email] wrote:

>Ok, with Maven 1.0.2 the build is succesful (sorry, didn't notice that the
>path was still pointing to the 1.1 version).
>But I still have problems building the war.
>After "maven war" the resulting war-file only contains the manifest file.
>
>Andreas
>
>
>
>
>                                                                                                                                          
>                      Guillaume Nodet                                                                                                      
>                      <guillaume.nodet@worl         An:      [hidden email]                                                  
>                      donline.fr>                   Kopie:                                                                                
>                                                    Thema:   *****SPAM***** Re: [servicemix-user] 2.0 build failed                        
>                      08.11.2005 13:30                                                                                                    
>                      Bitte antworten an                                                                                                  
>                      user                                                                                                                
>                                                                                                                                          
>                                                                                                                                          
>
>
>
>
>Servicemix is built with maven-1.0.2.
>I've just checked that the source distribution compiles well.
>You must have a jdk 5 installed to compile, even if servicemix
>is 1.4 compatible (some components use java 5 annotations, like jax-ws ...)
>
>This may be a bug with maven 1.1 beta.
>
>Guillaume
>
>Nathan Sowatskey wrote:
>
>  
>
>>1.1 builds fine, but ...
>>
>>rcdn-nsowatsk-3002-1:~/Documents/workspace/servicemix-2.0 nsowatsk$
>>maven
>>__  __
>>|  \/  |__ _Apache__ ___
>>| |\/| / _` \ V / -_) ' \  ~ intelligent projects ~
>>|_|  |_\__,_|\_/\___|_||_|  v. 1.1-beta-2
>>
>>DEPRECATED: the default goal should be specified in the <build>
>>section of project.xml instead of maven.xml
>>build:start:
>>
>>init:
>>    [echo] init basedir=/Users/nsowatsk/Documents/workspace/
>>servicemix-2.0
>>
>>default:
>>multiproject:projects-init:
>>    [echo] Gathering project list
>>Starting the reactor...
>>
>>BUILD FAILED
>>File...... /Users/nsowatsk/.maven/cache/maven-multiproject-
>>plugin-1.4.1/plugin.jelly
>>Element... maven:reactor
>>Line...... 64
>>Column.... -1
>>Unknown error reading project
>>Total time   : 4 seconds
>>Finished at  : Tuesday, November 8, 2005 12:23:17 PM CET
>>
>>rcdn-nsowatsk-3002-1:~/Documents/workspace/servicemix-2.0 nsowatsk$
>>
>>Nathan Sowatskey - Technical Leader, NMTG CTO Engineering -
>>+34-638-083-675, +34-91-201-2139 - AIM NathanCisco - [hidden email]
>>
>>
>>    
>>
>
>
>
>
>
>
>  
>

Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: [servicemix-user] 2.0 build failed

aschilling
In reply to this post by nsowatsk
Sorry, my fault!  :-(
Now it works in Tomcat (well, after commenting out a missing
hello-world-component in the applicationContext.xml  ;-)
Great!

Thanks!

Andreas





                                                                                                                                           
                      Guillaume Nodet                                                                                                      
                      <guillaume.nodet@worl         An:      [hidden email]                                                  
                      donline.fr>                   Kopie:                                                                                
                                                    Thema:   *****SPAM***** Re: [servicemix-user] 2.0 build failed                        
                      08.11.2005 14:18                                                                                                    
                      Bitte antworten an                                                                                                  
                      user                                                                                                                
                                                                                                                                           
                                                                                                                                           




In which directory do you call "maven war" ?
Look at http://servicemix.org/Tomcat+Integration
You must run the command in the \tooling\servicemix-web dir.
It works for me with the source dist.

Guillaume


[hidden email] wrote:

>Ok, with Maven 1.0.2 the build is succesful (sorry, didn't notice that the
>path was still pointing to the 1.1 version).
>But I still have problems building the war.
>After "maven war" the resulting war-file only contains the manifest file.
>
>Andreas
>
>
>
>
>

>                      Guillaume Nodet

>                      <guillaume.nodet@worl         An:
[hidden email]

>                      donline.fr>                   Kopie:

>                                                    Thema:
*****SPAM***** Re: [servicemix-user] 2.0 build failed

>                      08.11.2005 13:30

>                      Bitte antworten an

>                      user

>

>

>
>
>
>
>Servicemix is built with maven-1.0.2.
>I've just checked that the source distribution compiles well.
>You must have a jdk 5 installed to compile, even if servicemix
>is 1.4 compatible (some components use java 5 annotations, like jax-ws
...)

>
>This may be a bug with maven 1.1 beta.
>
>Guillaume
>
>Nathan Sowatskey wrote:
>
>
>
>>1.1 builds fine, but ...
>>
>>rcdn-nsowatsk-3002-1:~/Documents/workspace/servicemix-2.0 nsowatsk$
>>maven
>>__  __
>>|  \/  |__ _Apache__ ___
>>| |\/| / _` \ V / -_) ' \  ~ intelligent projects ~
>>|_|  |_\__,_|\_/\___|_||_|  v. 1.1-beta-2
>>
>>DEPRECATED: the default goal should be specified in the <build>
>>section of project.xml instead of maven.xml
>>build:start:
>>
>>init:
>>    [echo] init basedir=/Users/nsowatsk/Documents/workspace/
>>servicemix-2.0
>>
>>default:
>>multiproject:projects-init:
>>    [echo] Gathering project list
>>Starting the reactor...
>>
>>BUILD FAILED
>>File...... /Users/nsowatsk/.maven/cache/maven-multiproject-
>>plugin-1.4.1/plugin.jelly
>>Element... maven:reactor
>>Line...... 64
>>Column.... -1
>>Unknown error reading project
>>Total time   : 4 seconds
>>Finished at  : Tuesday, November 8, 2005 12:23:17 PM CET
>>
>>rcdn-nsowatsk-3002-1:~/Documents/workspace/servicemix-2.0 nsowatsk$
>>
>>Nathan Sowatskey - Technical Leader, NMTG CTO Engineering -
>>+34-638-083-675, +34-91-201-2139 - AIM NathanCisco - [hidden email]
>>
>>
>>
>>
>
>
>
>
>
>
>
>




Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: [servicemix-user] 2.0 build failed

Peter Smith-2
In reply to this post by Guillaume Nodet-3
Guillaume Nodet wrote:

> Servicemix is built with maven-1.0.2.
> I've just checked that the source distribution compiles well.
> You must have a jdk 5 installed to compile, even if servicemix
> is 1.4 compatible (some components use java 5 annotations, like jax-ws
> ...)


Is it possible to make the build of the ServiceMix engine independent
from that of the components. For example,

a) Upgrading to JDK 1.4 is going to be a problem for me... what can I
say - that's just the way it is  :-(

b) I am interested mainly in the ServiceMix JBI engine; Not necessarilly
in all components that come bundled with ServiceMix

c) I can foresee now it is only a matter of time before JDK 1.5 features
(accidentally?) creep into the engine as well.

Should I add a JIRA issue about this concern?

Thanks,
Peter.

Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: [servicemix-user] 2.0 build failed

Peter Smith-2
Peter Smith wrote:

> Guillaume Nodet wrote:
>
>> Servicemix is built with maven-1.0.2.
>> I've just checked that the source distribution compiles well.
>> You must have a jdk 5 installed to compile, even if servicemix
>> is 1.4 compatible (some components use java 5 annotations, like
>> jax-ws ...)
>
>
>
> Is it possible to make the build of the ServiceMix engine independent
> from that of the components. For example,
>
> a) Upgrading to JDK 1.4 is going to be a problem for me... what can I
> say - that's just the way it is  :-(

Sorry - I meant to say JDK 1.5 is going to be a problem.

>
> b) I am interested mainly in the ServiceMix JBI engine; Not
> necessarilly in all components that come bundled with ServiceMix
>
> c) I can foresee now it is only a matter of time before JDK 1.5
> features (accidentally?) creep into the engine as well.
>
> Should I add a JIRA issue about this concern?
>
> Thanks,
> Peter.
>
>

Loading...