[servicemix-user] SM 2.0.1 and DOMError

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

[servicemix-user] SM 2.0.1 and DOMError

Craig Walls

Another quirk I noticed with SM 2.0.1 is that its lib directory contains
xercesImpl-2.7.1.jar, which seems to be incompatible with jaxp-1.3.jar
which it also contains. When running ServiceMix (even the examples), I get
a message indicating that it can't find org.w3c.dom.DOMError. Switching
xercesImpl-2.7.1.jar back to xercesImpl-2.6.2.jar made everything start
working again.



Reply | Threaded
Open this post in threaded view
|

Re: [servicemix-user] SM 2.0.1 and DOMError

Guillaume Nodet-3
Thanks Craig,
this has been fixed in the 2.0 branch and will be part up the upcoming
2.0.2.
The other way is to use xml-apis-1.3.02.jar which contains the needed
xml apis.

Cheers,
Guillaume Nodet

Craig Walls wrote:

>Another quirk I noticed with SM 2.0.1 is that its lib directory contains
>xercesImpl-2.7.1.jar, which seems to be incompatible with jaxp-1.3.jar
>which it also contains. When running ServiceMix (even the examples), I get
>a message indicating that it can't find org.w3c.dom.DOMError. Switching
>xercesImpl-2.7.1.jar back to xercesImpl-2.6.2.jar made everything start
>working again.
>
>
>
>
>
>  
>