[servicemix-user] WARdon't work in Tomcat

classic Classic list List threaded Threaded
6 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

[servicemix-user] WARdon't work in Tomcat

aschilling
Hello,

I just tried to run ServiceMix in Tomcat.
But the examples mentioned on the "WAR+Deployment" page don't work.
At least there's a web.xml missing in the servicemix.war.

Does anybody know how to fix this?

Thanks!

Andreas

Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: [servicemix-user] WARdon't work in Tomcat

Guillaume Nodet-3
I've just run the "maven war" command, and the war contains the web.xml.
This seems strange.

Guillaume

[hidden email] wrote:

>Hello,
>
>I just tried to run ServiceMix in Tomcat.
>But the examples mentioned on the "WAR+Deployment" page don't work.
>At least there's a web.xml missing in the servicemix.war.
>
>Does anybody know how to fix this?
>
>Thanks!
>
>Andreas
>
>
>
>  
>

Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Re: [servicemix-user] WARdon't work in Tomcat

aschilling
In reply to this post by aschilling
I've also tried the war-build again  ...  still no web.xml!
I'm using the current (1.1) release of ServiceMix and maven 1.1beta2.
I switched off the tests ("maven -Dmaven.test.skip=true war").

Anyway, the only web.xml that exists in the servicemix directory structure
is
... \servicemix-1.1
\src\main\release\examples\xfire-binding\src\webapp\WEB-INF
Is this correct??

Regards,
Andreas







                                                                                                                                           
                      Guillaume Nodet                                                                                                      
                      <guillaume.nodet@worl         An:      [hidden email]                                                  
                      donline.fr>                   Kopie:                                                                                
                                                    Thema:   *****SPAM***** Re: [servicemix-user] WARdon't work in Tomcat                  
                      07.11.2005 12:31                                                                                                    
                      Bitte antworten an                                                                                                  
                      user                                                                                                                
                                                                                                                                           
                                                                                                                                           




I've just run the "maven war" command, and the war contains the web.xml.
This seems strange.

Guillaume

[hidden email] wrote:

>Hello,
>
>I just tried to run ServiceMix in Tomcat.
>But the examples mentioned on the "WAR+Deployment" page don't work.
>At least there's a web.xml missing in the servicemix.war.
>
>Does anybody know how to fix this?
>
>Thanks!
>
>Andreas
>
>
>
>
>




Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: [servicemix-user] WARdon't work in Tomcat

Guillaume Nodet-3
Could you try with maven 1.0.2, please.
It's a long time since i tried maven 1.1 but i experienced compatibility
problems with it.

The web.xml is in the following location
    servicemix\tooling\servicemix-web\src\webapp\WEB-INF

Cheers,
Guillaume Nodet

[hidden email] wrote:

>I've also tried the war-build again  ...  still no web.xml!
>I'm using the current (1.1) release of ServiceMix and maven 1.1beta2.
>I switched off the tests ("maven -Dmaven.test.skip=true war").
>
>Anyway, the only web.xml that exists in the servicemix directory structure
>is
>... \servicemix-1.1
>\src\main\release\examples\xfire-binding\src\webapp\WEB-INF
>Is this correct??
>
>Regards,
>Andreas
>
>
>
>
>
>
>
>                                                                                                                                          
>                      Guillaume Nodet                                                                                                      
>                      <guillaume.nodet@worl         An:      [hidden email]                                                  
>                      donline.fr>                   Kopie:                                                                                
>                                                    Thema:   *****SPAM***** Re: [servicemix-user] WARdon't work in Tomcat                  
>                      07.11.2005 12:31                                                                                                    
>                      Bitte antworten an                                                                                                  
>                      user                                                                                                                
>                                                                                                                                          
>                                                                                                                                          
>
>
>
>
>I've just run the "maven war" command, and the war contains the web.xml.
>This seems strange.
>
>Guillaume
>
>[hidden email] wrote:
>
>  
>
>>Hello,
>>
>>I just tried to run ServiceMix in Tomcat.
>>But the examples mentioned on the "WAR+Deployment" page don't work.
>>At least there's a web.xml missing in the servicemix.war.
>>
>>Does anybody know how to fix this?
>>
>>Thanks!
>>
>>Andreas
>>
>>
>>
>>
>>
>>    
>>
>
>
>
>
>
>
>  
>

Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: [servicemix-user] WARdon't work in Tomcat

aschilling
In reply to this post by aschilling
Ok, here's what I did:

I downloaded servicemix-1.1-src.zip
I unzipped it.
The resulting directory structure did not contain a "tooling" directory and
the only web.xml was the one I mentioned in my last posting.
I ran "maven -Dmaven.test.skip=true"  (now with maven version 1.0.2)
I ran "maven -Dmaven.test.skip=true war"
Still there is no "tooling" directory and only the XFire example web.xml.

Any ideas?
Thanks again!

Andreas




                                                                                                                                           
                      Guillaume Nodet                                                                                                      
                      <guillaume.nodet@worl         An:      [hidden email]                                                  
                      donline.fr>                   Kopie:                                                                                
                                                    Thema:   *****SPAM***** Re: [servicemix-user] WARdon't work in Tomcat                  
                      07.11.2005 13:50                                                                                                    
                      Bitte antworten an                                                                                                  
                      user                                                                                                                
                                                                                                                                           
                                                                                                                                           




Could you try with maven 1.0.2, please.
It's a long time since i tried maven 1.1 but i experienced compatibility
problems with it.

The web.xml is in the following location
    servicemix\tooling\servicemix-web\src\webapp\WEB-INF

Cheers,
Guillaume Nodet

[hidden email] wrote:

>I've also tried the war-build again  ...  still no web.xml!
>I'm using the current (1.1) release of ServiceMix and maven 1.1beta2.
>I switched off the tests ("maven -Dmaven.test.skip=true war").
>
>Anyway, the only web.xml that exists in the servicemix directory structure
>is
>... \servicemix-1.1
>\src\main\release\examples\xfire-binding\src\webapp\WEB-INF
>Is this correct??
>
>Regards,
>Andreas
>
>
>
>
>
>
>
>

>                      Guillaume Nodet

>                      <guillaume.nodet@worl         An:
[hidden email]

>                      donline.fr>                   Kopie:

>                                                    Thema:
*****SPAM***** Re: [servicemix-user] WARdon't work in Tomcat

>                      07.11.2005 12:31

>                      Bitte antworten an

>                      user

>

>

>
>
>
>
>I've just run the "maven war" command, and the war contains the web.xml.
>This seems strange.
>
>Guillaume
>
>[hidden email] wrote:
>
>
>
>>Hello,
>>
>>I just tried to run ServiceMix in Tomcat.
>>But the examples mentioned on the "WAR+Deployment" page don't work.
>>At least there's a web.xml missing in the servicemix.war.
>>
>>Does anybody know how to fix this?
>>
>>Thanks!
>>
>>Andreas
>>
>>
>>
>>
>>
>>
>>
>
>
>
>
>
>
>
>




Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: [servicemix-user] WARdon't work in Tomcat

Guillaume Nodet-3
Try downloading the sources from the following link.
It contains the whole source tree.

http://svn.servicemix.codehaus.org/branches/servicemix-1.1.tar.gz?view=tar

Cheers,
Guillaume Nodet

[hidden email] wrote:

>Ok, here's what I did:
>
>I downloaded servicemix-1.1-src.zip
>I unzipped it.
>The resulting directory structure did not contain a "tooling" directory and
>the only web.xml was the one I mentioned in my last posting.
>I ran "maven -Dmaven.test.skip=true"  (now with maven version 1.0.2)
>I ran "maven -Dmaven.test.skip=true war"
>Still there is no "tooling" directory and only the XFire example web.xml.
>
>Any ideas?
>Thanks again!
>
>Andreas
>
>
>
>
>                                                                                                                                          
>                      Guillaume Nodet                                                                                                      
>                      <guillaume.nodet@worl         An:      [hidden email]                                                  
>                      donline.fr>                   Kopie:                                                                                
>                                                    Thema:   *****SPAM***** Re: [servicemix-user] WARdon't work in Tomcat                  
>                      07.11.2005 13:50                                                                                                    
>                      Bitte antworten an                                                                                                  
>                      user                                                                                                                
>                                                                                                                                          
>                                                                                                                                          
>
>
>
>
>Could you try with maven 1.0.2, please.
>It's a long time since i tried maven 1.1 but i experienced compatibility
>problems with it.
>
>The web.xml is in the following location
>    servicemix\tooling\servicemix-web\src\webapp\WEB-INF
>
>Cheers,
>Guillaume Nodet
>
>[hidden email] wrote:
>
>  
>
>>I've also tried the war-build again  ...  still no web.xml!
>>I'm using the current (1.1) release of ServiceMix and maven 1.1beta2.
>>I switched off the tests ("maven -Dmaven.test.skip=true war").
>>
>>Anyway, the only web.xml that exists in the servicemix directory structure
>>is
>>... \servicemix-1.1
>>\src\main\release\examples\xfire-binding\src\webapp\WEB-INF
>>Is this correct??
>>
>>Regards,
>>Andreas
>>
>>
>>
>>
>>
>>
>>
>>
>>    
>>
>
>  
>
>>                     Guillaume Nodet
>>    
>>
>
>  
>
>>                     <guillaume.nodet@worl         An:
>>    
>>
>[hidden email]
>
>  
>
>>                     donline.fr>                   Kopie:
>>    
>>
>
>  
>
>>                                                   Thema:
>>    
>>
>*****SPAM***** Re: [servicemix-user] WARdon't work in Tomcat
>
>  
>
>>                     07.11.2005 12:31
>>    
>>
>
>  
>
>>                     Bitte antworten an
>>    
>>
>
>  
>
>>                     user
>>    
>>
>
>  
>
>
>  
>
>
>  
>
>>
>>
>>I've just run the "maven war" command, and the war contains the web.xml.
>>This seems strange.
>>
>>Guillaume
>>
>>[hidden email] wrote:
>>
>>
>>
>>    
>>
>>>Hello,
>>>
>>>I just tried to run ServiceMix in Tomcat.
>>>But the examples mentioned on the "WAR+Deployment" page don't work.
>>>At least there's a web.xml missing in the servicemix.war.
>>>
>>>Does anybody know how to fix this?
>>>
>>>Thanks!
>>>
>>>Andreas
>>>
>>>
>>>
>>>
>>>
>>>
>>>
>>>      
>>>
>>
>>
>>
>>
>>
>>
>>    
>>
>
>
>
>
>
>
>  
>

Loading...